Changes between Version 33 and Version 34 of FAQ


Ignore:
Timestamp:
Mar 22, 2013, 9:32:33 AM (8 years ago)
Author:
bsoher
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • FAQ

    v33 v34  
    1212
    1313'''[#SetupsaysIhaven'tgotthedependenciesinstalled(scipy,numpy,etc.),butIdo! Setup says I haven't got the dependencies installed (scipy, numpy, etc.), but I do!]'''
     14
     15'''[#InstallProblem1-IssuewithwidgetsorwxPython Install Problem 1 - Issue with widgets or wxPython]'''
    1416
    1517----
     
    5658
    5759
     60=== Install Problem 1 - Issue with widgets or wxPython ===
     61At this moment (March 2013), we recommend that you use wxpython version 2.8.x (more specifically 2.8.11.x or later). We develop Vespa using 2.8.12.1 under Windows, for example. There are changes under wxpython 2.9.x for which we have not tested/modified Vespa to account for. Part of this is time on our part, and part of it is that wx 2.9 is still sort of a moving target with the changes they make.  So we've decided to stick with wx 2.8.x versions for the time being.
     62
     63Try uninstalling wxpython 2.9 and installing wxpython 2.8.12.1 (or so) to see if that fixes these problems.
     64
     65More information (useless or otherwise) - We would prefer to require wxPython 2.8.11.0 because that's the first version that includes a version of floatspin.py that contains the patches we submitted. However, as of December 2012, the most current version of EPD (7.3) is still on wxPython 2.8.10.1 which is not sufficiently recent. Until EPD provides a more recent wxPython, we can't require 2.8.11.0.
     66
     67Here is a link to some more general comments on the versions of dependency modules required for Vespa.
     68
     69[wiki:Downloads Downloads]