Opened 9 years ago

Closed 4 years ago

#25 closed defect (fixed)

Simulation: Experiment visualize tab output to PNG fails under OS X

Reported by: flip Owned by:
Priority: minor Milestone:
Component: common Version:
Keywords: Cc: bsoher

Description

Under OS X, the menu item View->Output->1D/Stackplot->Plot to PNG creates a PNG, but it's always blank (pure white). Under Windows & Ubuntu, there's no problem; the PNG appears as expected.

Output to EPS, SVG and PDF all work fine under OS X.

When I attempt the output to PNG, I get this in the console window:

Tue Feb  8 13:13:03 zubr.local Python[44305] <Error>: kCGErrorIllegalArgument: _CGSFindSharedWindow: WID 45826
Tue Feb  8 13:13:03 zubr.local Python[44305] <Error>: kCGErrorIllegalArgument: CGSGetWindowTags: Invalid window 0xb302

That error doesn't seem to be happening at a level that generates a Python exception, so our Python code never sees it.

I'm filing this as a minor priority because output to PDF works and under OS X it's trivial to open the PDF and save as PNG. Granted, the extra step is annoying. I also suspect that the problem is caused by the code we're calling (matplotlib?) rather than ours, so there's not much we can do about it other than alerting them to the problem if they're not already aware of it.

I filed this as a Vespa bug rather than a Simulation bug because I'm sure this will crop up in our other apps.

Change History (2)

comment:1 Changed 9 years ago by flip

I noticed that when I output to PDF I get this error in the console. Despite that, the PDF output is correct.

Tue Feb  8 16:46:20 zubr.local Python[48567] <Error>: kCGErrorIllegalArgument: _CGSFindSharedWindow: WID 47377
Tue Feb  8 16:46:20 zubr.local Python[48567] <Error>: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.
Tue Feb  8 16:46:20 zubr.local Python[48567] <Error>: kCGErrorIllegalArgument: CGSGetWindowTags: Invalid window 0xb911

comment:2 Changed 4 years ago by flip

  • Resolution set to fixed
  • Status changed from new to closed

I don't know when this was fixed, but I can no longer re-create it under OS X 10.10.

Note: See TracTickets for help on using tickets.