Opened 10 years ago

Closed 8 years ago

#19 closed defect (fixed)

wxmpl.py causes deprecation warning w/matplotlib 0.99

Reported by: flip Owned by:
Priority: minor Milestone:
Component: common Version:
Keywords: Cc: bsoher

Description

This was originally a ticket in our now-defunct wx Trac instance. It appears that wxmpl is on the way to being removed from this project, but I'd like to leave this ticket around until we know it's gone.


wxmpl.py imports matplotlib.numerix, and as of matplotlib 0.99 there's a deprecation warning whenever one imports matplotlib.numerix.

We're using wxmpl 1.3.1 and as of this writing that's the latest available on their Web site, so we can live with the warning, patch it ourselves or wait for the wxmpl folks to fix it.

Here's the error:

Y:\duke\src\vespa\analysis\src>python main.py
c:\Python25\lib\site-packages\matplotlib\numerix\__init__.py:18: DeprecationWarning:
**********************************************************
matplotlib.numerix and all its subpackages are deprecated.
They will be removed soon.  Please use numpy instead.
**********************************************************

  warnings.warn(msg, DeprecationWarning)

Change History (1)

comment:1 Changed 8 years ago by flip

  • Cc bsoher added
  • Resolution set to fixed
  • Status changed from new to closed

Fixed thanks to Brian's changes in r2868, r2869, r2871

Note: See TracTickets for help on using tickets.